Mises à jour de février, 2008 Activer/désactiver les fils de commentaires | Raccourcis clavier

  • freyafinker 2:45 pm le February 23, 2008 Permalien | Réponse
    Tags : Simplepie Wordpress   

    Simplepie plugin pour WordPress 

    Comme je vous l’annonçais dans un post précédent, l’utilisation du plugin Simplepie pour WordPress serait sans doute susceptible de permettre très facilement l’affichage d’un flux RSS sur un blog WordPress.

    Et effectivement, ça marche avec quelques petits bémols…

    En tapant Simplepie WordPress dans Google, on tombe sur la page du plugin : http://simplepie.org/wiki/plugins/wordpress/simplepie_plugin_for_wordpress

    Très vite on peut le télécharger en cliquant sur download (petite remarque la version marquée est 2.1.1 mais le téléchargement donne la version 2.1). On le décomprime en cliquant droit « extraire tout » avec la souris. On ouvre le dossier dans lequel se trouve un nouveau dossier. C’est ce dernier que l’on va transférer sur le serveur dans le dossier wp-content/plugins/. On peut alors aller activer le plugin « activate plugin » dans le tableau de bord de WordPress. (à ce stade un petit rappel, vous ne pouvez utiliser les plugins que si vous avez installé WordPress sur votre serveur). Simplepie se retrouve alors accessible dans les options de wordpress. En même temps, dans la page plugins, on trouve qu’il existe une version 2.1.2 du plugin et on peut le télécharger.

    Alors là, méga message d’erreur qui nous dit que Simplepie WordPress n’est pas installé au bon endroit ! J’ai donc téléchargé la version 2.1.2 et je l’ai mise à la place de la version 2.1. Victoire, ce message d’erreur disparaît.

    Pour en laisser un second (de message d’erreur) qui nous dit que le cache n’est pas inscriptible (cache not writeable). Pourtant, j’ai créé un dossier cache dans wp-content et j’ai modifié ses attributs pour avoir un chmod à 777.

    J’ai essayé de mettre la commande (à entourer des commandes php):

     echo SimplePieWP('http://simplepie.org'); 

    quelque part dans mon template wordpress. Ca marche. Malgré le message d’erreur le flux est affiché correctement (ici à titre d’exemple c’est le flux de Simplepie qui est affiché).

    Reste à faire disparaître ce message d’erreur. J’ai essayé de le supprimer dans le code, j’ai recherché une solution sur les forums de wordpress, et finalement après plusieurs essais infructueux, j’ai réussi à le supprimer en allant dans options, simplepie, et en choisissant de ne pas utiliser le cache. Donc solution temporaire peu élégante, mais comme j’agrège peu de flux, ce n’est certainement pas grave. Par rapport à l’article précédent où il fallait 20 lignes de code pour afficher un flux, c’est devenu hyper-simple.

    On peut modifier les paramètres, tels que le nombre d’articles, la longueur du résumé affiché, simplement dans la page options simplepie de wordpress.

    Ah oui, chez WordPress ils disent que le problème cache not writeable est résolu en repassant à la version 2.1 (mais moi dans ce cas j’ai d’autres messages d’erreurs). Ou alors ailleurs, ils disent que le problème finit par se résoudre tout seul. Patience, patience.

    Pour finir, un petit exemple copié sur la page du plugin qui montre bien comment on donne les adresses des flux, et comment on choisit le nombre d’articles (items) à afficher, si l’on veut faire afficher plusieurs flux (code à encadrer par des balises php).

    
    echo SimplePieWP(array(
    	'http://feeds.feedburner.com/simplepie',
    	'http://laughingmeme.org/category/magpie/feed/'
    ), array(
    	'items' => 5,
    	'cache_duration' => 1800,
    	'date_format' => 'j M Y, g:i a'
    ));
    
    
     
    • micheljo 7:49 le mars 28, 2008 Permalien | Réponse

      Bonjour,
      j’essaye en vain d’utiliser simplepie et simplepie core.
      Je suis novice, et quand je tente de coller
      echo SimplePieWP(array(
      ‘http://feeds.feedburner.com/simplepie‘,
      ‘http://laughingmeme.org/category/magpie/feed/’
      ), array(
      ‘items’ => 5,
      ‘cache_duration’ => 1800,
      ‘date_format’ => ‘j M Y, g:i a’
      ));
      dans le code de mon article, en visuel, j’otiens ceci
      Quels sont les balises php pour encadre le code?
      est-ce que je dois mettre ce code dans l’article, ou ailleurs?
      Merci de m’aiguiller, soit par une réponse, ou un lien vers un bon tutoriel

    • micheljo 7:52 le mars 28, 2008 Permalien | Réponse

      excusez moi,
      en visuel, j’obtiens ceci

      ‘http://feeds.feedburner.com/simplepie‘,
      ‘http://laughingmeme.org/category/magpie/feed/’
      ), array(
      ‘items’ => 5,
      ‘cache_duration’ => 1800,
      ‘date_format’ => ‘j M Y, g:i a’
      ));

    • freyafinker 10:00 le mars 31, 2008 Permalien | Réponse

      Pour afficher un flux dans un article, il va falloir activer php, pour cela, voir l’article suivant :
      https://freyafinker.wordpress.com/2007/09/09/les-plugins-de-wordpress/

      Pour tester le code, on peut le faire afficher dans les colonnes du blog, à partir du template de wordpress, à condition de savoir comment modifier son template, voir ceci :
      https://freyafinker.wordpress.com/2008/02/10/comment-organiser-les-liens-de-son-blog-wordpress/

      Enfin les commandes php, qui sont zappées dans les articles wordpress et sûrement les commentaires, c’est pourquoi je les décortique sont :
      (avant le code) :

    • freyafinker 10:02 le mars 31, 2008 Permalien | Réponse

      WordPress ayant zappé les commandes php, comme prévu, il faudra chercher ailleurs comment ouvrir et fermer une balise php.

      Désolée pour ma lenteur à répondre, n’hésitez pas à me solliciter si le problème n’est pas résolu.

      Encore un chose, pour entrer du code (comme php), il faut mettre l’éditeur en mode code.

    • abysse 10:16 le avril 27, 2010 Permalien | Réponse

      Bonjour,

      J’ai fait toutes les manips requises et j’obtiens l’erreur suivante :

      Parse error: syntax error, unexpected ‘<', expecting ')' in /homepages/9/d325145304/htdocs/abysse-tech/wp-content/plugins/exec-php/includes/runtime.php(42) : eval()'d code on line 1

      L'interprétation PHP est faite avec exec-php et fonctionne avec des echos simples

      D'ou cela peut-il venir ?

  • freyafinker 2:34 pm le November 17, 2007 Permalien | Réponse
    Tags : Pile freemen, Plugoo,   

    De la nécessité de bien tenir son weblog 

    J’ai un peu négligé ce blog et internet ces derniers temps, besoin de faire une pause, pas de projet exaltant, résultat j’ai larvé devant la télévision… et tout oublié…

    Résultat, pour bien installer un wordpress, j’ai dû retourner voir l’article de Freya Finker.

    Petit conseil, avant d’installer un wordpress, bien choisir le dossier dans lequel il sera au final, surtout si l’on se trouve dans des sous-domaines. En effet, lorsqu’on déplace le WordPress après installation, on tombe sur un message d’erreur ou parfois sur la racine du site (qui n’est pas sensée être visible par tout le monde), ça fait désordre. Il faut alors retourner dans la page ….wp-admin/install.php, vider toutes les tables et réinstaller WordPress (la dernière opération prend une seconde) mais si on ne veut pas perdre le contenu des tables il faut les déplacer, ou les renommer, ce qui est tout de même désagréable.

    J’aurais dû mieux noter quelle est la page à éditer pour changer la présentation de la page d’accueil, je n’arrive plus à la retrouver…

    Je voulais installer un tchat instantané Plugoo. C’est joli, c’est chouette et immédiat pour le visiteur du site qui n’a pas besoin de s’inscrire pour dialoguer. Plugoo permet d’avoir une conversation avec un visiteur de votre site (un à la fois pour l’instant) en utilisant sa messagerie instantanée favorite.

    Quand j’aurai trouvé, la démo sera sur la pile freemen à son adresse définitive.

     
    • lespacearcenciel 10:09 le novembre 18, 2007 Permalien | Réponse

      Re-bienvenue parmis nous, sur la toile. Ben alors, la télé c’est pas bon !
      Au fait, petite question : Tu en penses quoi de Facebook… ?
      Bises,
      Amitiés,
      Hugues 😉

      Ps – Doc Facebook :
      http://www.lespacearcenciel.com/?p=937

    • Freya Finker 7:44 le décembre 16, 2007 Permalien | Réponse

      Pour installer Plugoo, je n’ai eu qu’à m’inscrire, puis à coller le code dans le template de la page d’accueil, à l’intérieur de la colonne ad-hoc, bref c’est facile et ça fonctionne avec votre messagerie instantanée msn par exemple, bien lire les instructions.

c
créer un nouvel article
j
message/commentaire suivant
k
message/commentaire précédent
r
Réponse
e
Modifier
o
afficher/masquer les commentaires
t
remonter
l
connexion
h
afficher/masquer l'aide
shift + esc
Annuler